Back to overview
Website
Sep 28 at 10:16am NZST
Affected services
wildthings.club
Resolved
Sep 28 at 10:18am NZST
We’re back! The website should be up and running as normal. Thanks for bearing with us.
Affected services
Created
Sep 28 at 10:16am NZST
We’re having some trouble with the website loading in some regions. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services